Plenty of script-driven applications, particularly paid content management systems, encode their files in order to make sure that they will not be reverse engineered or tampered with. The majority of them use an app known as ionCube PHP Encoder to do this, so if you buy a paid script and you intend to set it up in a website hosting account, a software tool known as ionCube Loader needs to be present on your server. Without this, you won't be able to install the script or in case you somehow manage to do this, it won't function properly as most of the script code will be encrypted to a point where it can't be interpreted. In this light, you should ensure that ionCube Loader is present if you get a new hosting account and you want to use some paid web app. If you acquire a shared web hosting account and the tool is not present, it can't be added since your entire server PHP environment will have to be compiled again.

IonCube in Cloud Website Hosting

When you aquire a Linux cloud website hosting through our company, it'll be created on our custom cloud platform where ionCube Loader is already installed, so you will not have any kind of problems to manage any script app that requires the tool in order to run appropriately. In addition, we offer you a few different releases of PHP, so in case you switch the version, you'll have to enable ionCube again. Our system remembers the changes you make, so when you move back to the previous release of PHP that was active for your account, ionCube Loader will already be enabled. The PHP version as well as the ionCube tool can be operated from the PHP Configuration section of our Hepsia web hosting Control Panel. Each change that you do takes literally just a click and it will take effect at once.

IonCube in Semi-dedicated Hosting

Since all of the semi-dedicated server accounts are set up on our advanced cluster platform and ionCube Loader is available on it, you will be able to use any script app that requires this tool in order to function properly. With several clicks in your Hepsia website hosting Control Panel you can activate or deactivate ionCube for the PHP version that is currently active for the account. Since we support several releases of PHP at the same time, you'll need to do that each time you switch to a different version, and when you revert back to a version that you've already used, our system will remember your preference and ionCube Loader will already be active. When you have a couple of sites in the same account and they need different versions of PHP, you'll be able to set up a php.ini file in each domain folder and with a couple of lines of code you will be able to define both the PHP version and the status of ionCube regardless of what is selected for the web hosting account altogether.